Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

install on raspberry os with php 7.3 and ngix #35


Hi there,

I just tried to install in raspberry OS with ngix, without any error, but yet, when I open the page to use it, it just showes "404 nginx/1.14.2"

Any hint on how to solve or troubleshoot this issue ?


  • replies 8
  • views 2.3K
  • likes 0

That implies your nginx config isn't right, or you're using the wrong url to access rompr.


Thank you!

It was working, before rebooting, then it just stopped working.

Nginx aparently is working:

* nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2020-08-10 14:08:52 BST; 3h 33min ago
     Docs: man:nginx(8)
 Main PID: 563 (nginx)
    Tasks: 5 (limit: 2068)
   CGroup: /system.slice/nginx.service
           |-563 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
           |-564 nginx: worker process
           |-565 nginx: worker process
           |-566 nginx: worker process
           `-567 nginx: worker process

The only thing on port 6608:

sudo netstat -tlpn | grep 6680
tcp        0      0*               LISTEN      472/python3

Any hint ?


Hmm. Send the nginx config files, and tell me what url you are putting in your browser to access rompr.

Also, check the php-fpm config. This sounds like something got changed in a config file, but it only took effect when you rebooted.


Here it goes:

# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# In most cases, administrators will remove this file from sites-enabled/ and
# leave it as reference inside of sites-available where it will continue to be
# updated by the nginx packaging team.
# This file will automatically load configuration files provided by other
# applications, such as Drupal or Wordpress. These applications will be made
# available underneath a path with that package name, such as /drupal8.
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.

# Default server configuration
server {
        listen 80;
        listen [::]:80;

        # SSL configuration
        # listen 443 ssl default_server;
        # listen [::]:443 ssl default_server;
        # Note: You should disable gzip for SSL traffic.
        # See:
        # Read up on ssl_ciphers to ensure a secure configuration.
        # See:
        # Self signed certs generated by the ssl-cert package
        # Don't use them in a production server!
        # include snippets/snakeoil.conf;

        root /var/www/html;

        # Add index.php to the list if you are using PHP
        index index.html index.htm index.nginx-debian.html index.php;

        server_name _;

        location / {
                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                try_files $uri $uri/ =404;

        # pass PHP scripts to FastCGI server
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
        #       # With php-fpm (or other unix sockets):
                fastcgi_pass unix:/run/php/php7.3-fpm.sock;
        #       # With php-cgi (or other tcp sockets):
        #       fastcgi_pass;

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #location ~ /\.ht {
        #       deny all;

# Virtual Host configuration for
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#server {
#       listen 80;
#       listen [::]:80;
#       server_name;
#       root /var/www/;
#       index index.html;
#       location / {
#               try_files $uri $uri/ =404;
#       }


server {

    listen 80 default_server;
    listen [::]:80 default_server;

    root /home/pi/rompr;
    index index.php index.html index.htm;


    client_max_body_size 256M;

    # This section can be copied into an existing default setup
    location / {
        allow all;
        index index.php;
        location ~ \.php {
                try_files $uri index.php =404;
                fastcgi_pass unix:/var/run/php/php7.3-fpm.sock;
                fastcgi_index index.php;
                fastcgi_param SCRIPT_FILENAME $request_filename;
                include /etc/nginx/fastcgi_params;
                fastcgi_read_timeout 1800;
        error_page 404 = /404.php;
        try_files $uri $uri/ =404;
        location ~ /albumart/* {
                expires -1s;

The url is just the ip address of my installation machine


That is all correct.

Does /var/run/php/php7.3-fpm.sock exist?



Yes, it does!

ls /var/run/php/php7.3-fpm.sock


Well, I can't explain that. I would check the instructions again, make sure your config files are in the correct place - some distributions have a 'sites-available' and a 'sites-enabled' directory, for example. Also check the nginx log files, perhaps there are some error messages there that might help.

If I'm honest I am thinking of changing the default install instructions to remove the thing as it seems to create more problems than it solves. Configuring nginx is not easy. If there's anything in the nginx log files and you can't figure it out, post it here and I'll take a look.

I just set this up last night. I was getting a 502 bad gateway error.

I put the extracted zip in /var/www/rompr. I changed permissions on that folder:

chown -R www-data rompr
chgrp -R www-data rompr

Changed the root in the config to

root /var/www/rompr;

Soon as I did that, everything worked.