Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

Testing Jetty server #46

Hi. I am trying to use JasperReports integration for the first time. I am using the included Jetty server, Oracle database XE 18c and Windows 7.
I am following the quick start guide
I downloaded the zip folder, configuired database access through adding schema credentials in file as follows...

username=hr password=hr

this parameter is limiting access to the integration for the

specified list of ip addresses, e.g.:


if the list is empty, ALL addresses are allowed

Then I deployed the jri.war file successfully. Then I started the server successfully as well. But when I tried to test it through http://localhost:8090/, I got the following page, and I do not know if that's the norm or there's something wrong...
Jetty Error.png

I need to know if testing is successful, and what's meant by "context" here?

  • solved #2
  • replies 2
  • views 929
  • likes 0

No, everything is fine. It shows you that the application "JasperReportsIntegration" is available and started. You are good to go :).

I might update the documentation so that people don't get confused.

EslamElbyaly accepted post #2 as the answer