Dietmar Aust

daust ·

Enable client to send report directly to it's printer

Hi,

well, I guess not.

The way it works is that the printing is done from the application server, in your case on the machine hosting the ORDS or Tomcat server. This server will have a printer attached (either physically or through the network). JRI ca...

Error With Generating report

Hi @aziddam,

this is typically a server issue with missing installed fonts on the system.

See: https://stackoverflow.com/questions/4998762/could-not-initialize-class-net-sf-jasperreports-engine-util-jrstyledtextparser

Does that help?
Best
~Dietmar.

JasperReportsIntegration-2.4.0.0 Dont Work with Oracle21c XE

Hi @oegidio,

thank you for the feedback and finding a solution!

All the best
~Dietmar.

Saving Jasper Report output

help wanted

Sure,

simply use the function get_report() instead of show_report(). It will return a blob which you can simply insert into the database.

Best,
~Dietmar.

Report the is blank

hi @robertopz,

hhhhmmm. Looks alright so far.

Are you certain, that the blob which is returned, contains the correct PDF?

Can you please try to display it in the browser to make sure the PDF is correct?

Please use the following code instead of se...

JRI Path Reports to S3 on AWS

Hi @oegidio,

good question.
Is it possible to "mount" the AWS directory as a regular filesystem on your Tomcat server?
Then you can use the reportsPath parameter in the application.properties configuration file:

# report definition files will be looked...

JDBC Connection is becomes Inactive and Occupied the processes & Exceeds 400 limit

help wanted

Hi @lakshmis2022,

do you still have this issue?

Not exactly sure, how I can help here. I am using Oracle JDBC driver (ojdbc8.jar) and Universal Connection Pool (ucp.jar) for the connection pooling with this code:

Greenshot 2023-09-14 12.22.21.png

Thus, the connection pool is lim...

Problem calling jasper report from Apex.

Hi @Hcalderonq,

it seems like you are running into the issue as described in the FAQ/Troubleshooting section: https://github.com/daust/JasperReportsIntegration#faq

Screenshot FAQ

Does that help?
Best
~Dietmar.

Multiple file output

Hi @yk652,

please elaborate a bit on your use case, I don't fully understand it yet.

In the browser, you can only display one PDF at the time.
Thus, do you want to ...

  1. Print several files directly to a printer?
  2. Store several files on t...

Weblogic jndi data source setup ?

Wonderful!!!

Thank you for raising it and improving the project. I will update the documentation to clarify the usage on Weblogic. I typically use my built-in connection pool through the application.properties file only.

Thanks again
~Dietmar.

Weblogic jndi data source setup ?

I could make it work on my system.
I had to change this setting in the application.properties file though:

jndiPrefix=

Give it a try, Dietmar.

Weblogic jndi data source setup ?

Which is your version of JasperReportsIntegration, 2.10.1?
Which operating system is Weblogic running on ... Windows?

Thank you.

Using Barcodes with fonts

help wanted
<?xml version="1.0" encoding="UTF-8"?>
<!-- Created with Jaspersoft Studio version 6.19.1.final using JasperReports Library version 6.19.1-867c00bf88cd4d784d404379d6c05e1b419e8a4c  -->
<jasperReport xmlns="http://jasperreports.sourceforge.net/jasperreports...

Using Barcodes with fonts

help wanted

I am using jasperintegration version 2.4.0 , I have created a report with a font ( Font requires pdf encoding identity-H ), which in preview of jasperstudio shows barcodes. However the barcodes are not shown when report is compiled and used through jri, ...

Using Barcodes with fonts

help wanted

The other issue I cannot reproduce either.
I created a simple test case since you didn't provide one ... again.

Greenshot 2023-04-20 16.44.05.png

This one worked right off the bat without me doing anything ... but copying the Bar... to the windows machine.I used jri-2.10.1-jasper-6.20.0

Using Barcodes with fonts

help wanted

I could make it work. I created a simple test case on my Macbook.

Greenshot 2023-04-20 16.32.33.png

Using Barcodes with fonts

help wanted

Well, then this seems to be a font issue ... not related to the two different barcode components that you can use in JasperReports.
Busy today ... might take a bit to build a testcase and try it.
Will get back to you.

Using Barcodes with fonts

help wanted

ok, please provide a simplified test report, then I can have a look.

Using Barcodes with fonts

help wanted

Hi, version 2.4.0 is really old. You have to make sure to build reports using a version of jasperstudio that supports the old engine (JasperReports 6.4.1).

When you create a simple test report I can give it a try ... but I will try with the latest relea...

Thai Language not showing

Ok, you are taking a different approach and not using the backend with pl/sql but rather Javascript from the frontend. Please be aware of the security implications because every user can access your datasource now.

Anyhow. First, you need to make sure tha...

SSL giving error

This is a basic ssl communication issue when dealing with Oracle. This is "below" the JasperReportsIntegration and even APEX.

Here is a simple check to make sure the SSL wallet is referenced correctly: https://github.com/daust/JasperReportsIntegration#run...

user_install.sql giving error

Great!

For the ACLs you have a sample script to allow them.
In the documentation you will find instructions for running it with SSL: https://github.com/daust/JasperReportsIntegration#accessing-jasperreportsintegration-through-ssl

Generally speaking, sin...

user_install.sql giving error

Hi,

please use the latest release and make the following change in the file xlib_http.pks in line 39:

HTTP_VERSION_1_1 constant VARCHAR2(64) := 'HTTP/1.1'; -- #123

=>

HTTP_VERSION_1_1 VARCHAR2(64) := 'HTTP/1.1'; -- #123

So, basically, when you...

user_install.sql giving error

I will have a look later today. Still busy. First I need to set up an environment so that I can test it ... on an older release. Please bear with me. Thanks. Want to make sure, it works flawlessly this time.