Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

Java version error? #39

#1

We are doing a new install on a new server, everything seems to be working fine, we can connect with the database without any issue

basic_connect.png

However, we are getting this error when running the test report

tomcat_error.png

This is our current configuration

jasper_config.png

Everything is on Oracle Linux 8, Tomcat 9.0.64, OpenJDK 18.0.1.1

Any help would be appreciated.

Thanks

  • replies 7
  • views 51
  • likes 0
#2
#3

Hello

I'm afraid is not working either. I'm getting the same error

jaspser2.9_config.png tomcat2.9_error.png
#4

Hello

I also tried with JDK version 17 and still the same error.

#5

Hello again

Just to inform that I was able to run the test successfully with Java version 16, keeping JRI on version 2.8.1

Best regards.

#6

Hi @jeanomobono ,

thank you for trying these different things.
Currently, I am at a conference in Chicago, traveling. I will be back next week.

Anyhow, is has become an increasing challenge to satisfy these different versions of Java, and even Tomcat. In Tomcat10, major apis have been renamed.

But I will look into this.

The way to go should be to use the latest versions of each software ... but many companies are slow to adopt for their own reasons.

So this poses a huge challenge for me.

What versions should I focus on? I cannot maintain versions for different JDK / Tomcat combinations.

Thank you
~Dietmar.

#7

Hi @daust

I think I speak for everyone on this forum when I say just "Thank you" for this amazing work you are doing. We know that working on these projects can be a huge task.

In my case, I will try to adapt to what is available.

Thanks again.

#8

Hi @jeanomobono,

I really appreciate your comment - many thanks for that.
I appreciate your approach and I typically do the same - for myself.

Nevertheless, I am here to help also those, who have more trouble adapting and finding alternative ways.
I will have a look later at the original issue.

Thanks again
~Dietmar.