Your browser was unable to load all of the resources. They may have been blocked by your firewall, proxy or browser configuration.
Press Ctrl+F5 or Ctrl+Shift+R to have your browser try again.

Tomcat error after updating libraries #34

#1

Hallo,

I'm using JasperReportsIntegration for many years now. It is a great great solution.
I'm still running with JasperReportsIntegration 2.1.0.0 and JasperReports 6.2.0 on Tomcat 9.0.10.
Now I decided it is time to update. But I did not install the latest JasperReportsIntegration files.
I only updated to the latest JasperReports Release. Meaning that I just deleted the jar libraries from the WEB-INF/lib folder on my Tomcat and copied the latest libraries from JasperReports 6.19.0 into the folder.
But after restarting Tomcat and calling the Test URL I receive an HTTP Status 404, "The origin server did not find a current representation for the target resource or is not willing to disclose that one exists."
Any idea why this occurs and how to fix it?
Regards, Peter

  • solved #5
  • replies 6
  • views 394
  • likes 0
#2
pwunderland · Author
#3

Hallo Dietmar, many thanks.
After updating it looks a little bit better. Test URL http://myhost:8080/jri/ is working.
But when running the APEX report demos I receive an "network access denied by access control list (ACL)" error. I remember that I had to do something with the old installation. But so far I was not able to fix it with.
Any help appreciated.
Regards, Peter

pwunderland · Author
#4

OK, I was able to fix my APEX implementation and am able to run my JasperReports.

The APEX report demos from JasperReportsIntegration still throw an ACL error. But that is currently ok for me as my implementation is working ;-) I will have a look later.

Regards, Peter

#5
pwunderland accepted post #5 as the answer
#6
pwunderland · Author
#7

Many thanks. I missed that one. regards, Peter